Problem

For the over 200 GNOME packages we maintain for each SLE / Leap releases, it would ideal to keep each of them up to the latest upstream patch version on correspondent branches. Currently we don't seem to do it globally and I hope to improve that.

Ideas

  • For Factory, osc-plugin-collab is used to keep GNOME:Next up with the latest upstream release. I'll investigate if it could be configured to work for our scenario before inventing wheels.
  • If that doesn't work. I'll borrow the idea and write some scriptlets for the simplest functionalities: notifications, reports etc or even automatic obs pull requests. That should be adequate, as patch updates on stable branches are not as intense as in GNOME:Next after all.

Looking for mad skills in:

Nothing? Add some keywords!

This project is part of:

Hack Week 18


Comments

Be the first to comment!

Similar Projects

This project is one of its kind!