Which package currently provides libfoo.so.6 ?

A question for/from packagers and currently not easy to answer, even if the Build Service might know about the content of packages inside a repository as he created the nice filelist.gz files inside the repomd directories with all the needed information already.

Maybe this can be integrated into the general search of the openSUSE Build Service, which already has some special search options included.

Main questions would be: <ul> <li>how to get the latest file lists of a repository into some database ?</li> <li>how to integrate this database into the OBS search?</li> <li>how to integrate all together in osc ?</li> </ul>

I'm unsure how far this project will come, but I guess it might be definitely worth the work.

Looking for hackers with the skills:

python sql

This project is part of:

Hack Week 10

Activity

  • almost 7 years ago: ancorgs disliked this project.
  • almost 8 years ago: gameboy974 liked this project.
  • almost 8 years ago: hennevogel disliked this project.
  • almost 8 years ago: jnweiger liked this project.
  • almost 8 years ago: lrupp liked this project.
  • almost 8 years ago: lrupp left this project.
  • almost 8 years ago: jreidinger liked this project.
  • almost 8 years ago: oholecek liked this project.
  • almost 8 years ago: ancorgs liked this project.
  • almost 8 years ago: coolo liked this project.
  • All Activity

    Comments

    • cb400f
      almost 8 years ago by cb400f | Reply

      I think benJIman has already done most of the work. http://webpinstant.com/search/libfoo.so.6

    • sleep_walker
      almost 8 years ago by sleep_walker | Reply

      Since we ask this question quite often in L3, I spent some time on tool (for now) called whichpkg. You can find it in here: https://build.opensuse.org/package/show/home:sleep_walker:l3/whichpkg

      or in l3-scripts GIT repository on bolzano.suse.de.

      It's intended to be used within internal network with schnell and dist mounted. And yes, it's limited: 1] works only on medias with ARCHIVE.gz, no maintenance updates 2] can't tell you important information about package metadata

      I'd love to see revived pdb.suse.de or merged its functionality into build service...

    • jnweiger
      almost 8 years ago by jnweiger | Reply

      Thomas: There is a packaging Problem: nothing provides /bin/bash4 needed by whichpkg-0.2-3.1.noarch

    • jnweiger
      almost 8 years ago by jnweiger | Reply

      http://webpinstant.com is cool! Maybe it is sufficient to advertise this properly?

    Similar Projects

    YAML 1.2 Schema support for PyYAML by tinita

    [comment]: # (Please use the project descriptio...


    Resurrect NWS CLI project by seanmarlow

    Project Description

    Many years back I cre...


    Create short "videos/screencasts" demoing cool stuff in 5 minutes by PSuarezHernandez

    [comment]: # (Please use the project descriptio...


    Learn python, python-gtk3, play with orangepi zero, experiment ili9341 and 20x4 LCD screen by aginies

    Project Description

    Learn python: get dat...


    Testing and adding GNU/Linux distributions on Uyuni by juliogonzalezgil

    Join the Gitter channel! [https://gitter.im/uy...